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Inspect and Fix Excel Document
Introduction

Finding and fixing issues in an Excel document by using both the accessibility checklist and the 
instructions in this guide will help resolve most Accessibility issues causing the document to be 
non-compliant. Creating an accessible document benefits all users.
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Inspecting and fixing Excel Documents

Adding a Document Title

Documents should have titles that describe their function or purpose of the document. It is 
usually the first content that is announced by screen readers instead of the file name. To give a 
title to a document complete the following steps:

1.	 Go to the top left of the document. Click on “File” tab.

2.	 After clicking on the File tab, Microsoft Office Backstage view will appear. Find the “Info” 
button to open the Document Properties window.
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3.	 To the right of the Info button is where the Info section is. Further right of the Info section 
find the “Properties” section.

 

4.	 Below where it says Properties locate the Title.
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5.	 To the right of Title select where it says, “Add a title” click on it and an input box will 
appear.

6.	 Write the document’s title it can be the same or different from the filename. This 
document title’s is “Non-Compliant Doc.”

7.	 Now the document has a title for the screen reader to read.
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Using Check Accessibility Tool and Fixing Issues 
It crucial to ensure that documents are accessible to people with disabilities. Checking and 
fixing accessibility issues in documents promotes inclusivity compliance with accessibility 
standards and grants equal access of information to users. It improves readability, 
usability, and navigation, benefiting all users. It will enhance user experience and facilitates 
understanding of content, fostering inclusivity, diversity, and equal opportunities for all to 
obtain information.

How to find and use the “Check Accessibility” tool.

The “Check Accessibility” is a tool that performs a full and thorough check for whether the 
document conforms to accessibility standards. It finds any issues such as the missing use of 
alternative text on images, presence of complex tables, missing document language, and hard-
to read fonts’ colors to be corrected. By following these steps, it’ll enable the checker to identify 
and address the accessibility issues in the document:

1.	 Go to the top left of the document. Click on “File” tab. 

2.	 After clicking on the File tab, you can see Microsoft Office Backstage view. Find the “Info” 
button to open the Document Properties window.
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3.	 To the right of the Info button is where the Inspect Document section.

4.	 Click the “Check for Issues” dropdown button.  

5.	 In the Check for Issues drop-down select the “Check Accessibility” option.  This will open 
“Accessibility Inspection Results.”
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6.	 The “Accessibility Assistant” box will now appear on the right of the document.

7.	 In the Inspection results it’ll show the issues making the document non-compliant. Select 
an issue to work on.
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Another Way to get to the Accessibility Checker

1.	 Click on the “Review” menu.

2.	 In the Review tab find the Check Accessibility button then click on it. 

3.	 A drop-down menu with options will appear. Select the Check Accessibility option.

4.	 Now you will see the “Accessibility Inspection Results” box to the right of the document.
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Some Accessibility Issues to Cover

Some of the issues that we will be covering are:

•	 Missing Object Description: Missing alternative text on an image.
•	 Use of Merged or Spilt Cells: Creation of a complex table.
•	 Hard-to-Read Text Contrast: Light or faint contrast between text and document back-

ground.
•	 Header Row: Missing header row on a table.

These are the most common issues to be found in a Excel document. Going over these common 
issues in this guide by inspecting and fixing the errors so that the document can become 
compliant. 

Fixing Accessibility Issue: Missing Object Description

Missing Object Description is crucial for individuals who are blind or visually impaired, as screen 
readers rely on alternative text, also known as alt text, to convey the meaning of images. 
Alt text allows these users to understand the context and purpose of the images making the 
document more accessible and inclusive. Additionally, alt text is useful in situations where the 
image cannot be displayed due to technical issues or when the document is being accessed by 
devices with limited visual capabilities. By providing accurate and descriptive alt text, it ensures 
that the document can be understood by a wider range of users.
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Giving Alternative Text to Images, Pictures, and Clip Art

It helps screen and document reading tools describe images to visually impaired readers. Giving 
alternative text when an image, picture or clip art does not have one or has a generated crated 
one can be done in a few steps:  There are two ways to give an images alternative text.

1.	 Right click on the image.
2.	  Select “View Alt Text” Option.

3.	 The “Alt Text” box will appear to the right of the document.
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4.	 In the input text box provide a description of the image. In this case write “Legislatively 
Approved Operating Appropriations Compared to the Spending Cap” to describe the 
image.

*If an image is of no importance such as it being decorative or line(s) to divide page  
or repeating logos/images that does not need to be read, then it can be marked as  

decorative instead. This will cause the screen reader to overlook the image. *

1.	 Below the input text box where the description of the image is given. Select the check box 
called “Mark as decorative” to checkmark it. 

Now the image will no longer be read out by screen readers, nor does it need alternative 
text.

2.	 The rest of Alt Text box will be greyed out/inaccessible to use after check marking the 
Mark as decorative check box.
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Fixing Accessibility Issues of Hard-to-Read Contrast

Setting a Good Color Contrast Ratio in Document

Text is easier to read when there is a good amount of contrast ratio between the text and page 
of the document. Good contrast is an ideal design choice for everyone and especially for those 
who have low vision. Hard-to-read text therefore lacks good contrast making the document 
difficult for people with both high and low vision to read. By follow these steps good contrast for 
the document can be accomplished:

1.	 Go to the Accessibility Assistant Inspection Results box to the right of the document.
2.	 Select the error Hard-to-Read Text Contrast. It’ll open the specific cause/location of the 

error.

3.	 Select the issue/problem that is causing the error, and the problem words or sentence will 
be highlighted in the document when it is selected from the Hard-to-Read Text Contrast 
error.
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4.	 The Hard-to-read text contrast box will open. Click on one of the colors under “Try one 
of these colors to resolve”. Excel will highlight the problem words or sentence in the 
document and will change the font color to what you selected. 

a.	 Note: If you don’t like any of the recommended colors, click on “More Font Colors” 
and choose another color. 
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b.	 If that doesn’t provide the results you are looking for, you can click on Page 
Background and change the color of the background to correct the color contrast 
issue. However, this is not recommended as this will change the background color of 
all pages in the document, not just the area you are trying to fix the color contrast 
on.

c.	 Once you’ve chosen a color with enough contrast to meet ADA requirements, the 
Accessibility Assistant will show the issue in a lighter gray text with a check mark to 
the right indicating the issue has been resolved.
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Document No Longer has Accessibility Issues

In the Accessibility Inspection Results there is now a green checkmark saying “No accessibility 
issues found. People with disabilities should not have difficulty reading this document.

Now this Excel document is compliant with all the accessibilty issues fixed 
meeting ADA standards. This document will now be accessible to everyone.
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WebAIM Contrast Checker 

What does WebAIM check for?

WCAG AA requires a contrast ratio of at least 4.5:1 for normal text and 3:1 for large text. 
WCAG AAA requires a contrast ratio of at least 7:1 for normal text and 4.5:1 for large text.

Web AIM Contrast Checker can check the color contrast of a document. Using it to check the 
text color and the background against different sizes of text will show if the contrast passes 
the required WCAG of both A and AA. It is recommended to pass AAA, when possible. If the 
contrast does not meet the above requirements, changes can be made by changing and/or 
adjusting the color contrast of the document’s content and background to make it easier to read 
the information and comply with ADA color contrast requirements.

Using the WebAIM Contrast Checker

Text is easier to read when there is a sufficient contrast between the page background and the 
text or other elements on the page. If unsure what would be an acceptable color for a good 
color contrast ratio, then changing to a darker version of the font color may help. For a more 
accurate contrast choice you can use a color contrast checker. A good resource is to use Web 
AIM Contrast Checker Website Resource, an online checker to verify WCAG AA and WCAG AAA 
compliancy from normal to large size text.

Foreground (Text) Color

1.	 Once the website has opened the Contrast Checker can be used.

https://webaim.org/resources/contrastchecker/
https://webaim.org/resources/contrastchecker/
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2.	 Go to the document and click on the Home Tab.

3.	  Select the words/sentences with the contrast error. 

4.	 Find the “Font Color” tool and select the arrow next to the tool. A drop-down menu will 
appear with color options. 

Select the “More Colors.”  
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5.	 The “Colors” box will appear.

6.	 Select the “Custom Tab.”
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7.	 Find where it says “Hex,” in its input box that is the hexadecimal number of the font color 
that is causing the error to the document.

8.	 Copy the hexadecimal number of the font color.

9.	 Once the hexadecimal number is copied go back to the Web AIM Contrast Checker 
website.

10.	 In the Contrast Checker website find the “Foreground Color input box and copy the 
hexadecimal number copied in Step 9 into the input box.”

https://webaim.org/resources/contrastchecker/
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11.	 Then press the “tab” key on the keyboard. Now the text color from the document will 
appear.

Background (Page) Color

If the background color of the document you are checking for color contrast is white, you can 
skip checking the background color (skip to Step 18 below) as WebAIM Color Contrast Checker 
defaults to white. If a background color has been applied, follow the steps below:

12.	 Enter page color in the search bar at the top of the word document

13.	 Then choose Page color from the drop-down menu
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14.	 Then choose More Colors at the bottom of the Theme Colors drop-down menu.

15.	 Locate the Hex field input box, and copy the Hexadecimal code in the input box. 

16.	 Open the WebAIM Color Contrast Checker and paste the hexadecimal code you copied into 
the background Hex Value input field. The color picker under the hex value will show the 
background color.
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17.	 Check to see if the Contrast Checker passed the color of the document. Scroll down the 
website to see if it passes WCAG standards in “Normal,” “Large” and “Graphical Objects 
and User Interface Components with a minimum of AA.” If it does not go the top of the 
webpage, back to Foreground Color.

18.	 Under the hexadecimal number input box there is a tool called “Lightness.”

19.	 In the Lightness tool there is a sliding bar tool. It is used to change the color that is in the 
hexadecimal input box. It makes the color darker or lighter depending on where the slide 
tool is positioned. The hexadecimal number will change depending on the position of the 
slide tool.
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20.	 Once you’ve found a contrast ratio color that has passed the WCAG’s standards, the 
Checker will provide you with a pass for all WCAG AA normal text, large text and graphical 
objects and user interface components. It is recommended to pass AAA, whenever 
possible.

21.	 Select the new hexadecimal color from the Contrast Checker and right-click and choose 
Copy from the drop-down menu.

22.	 Go back to the Microsoft Word document. Then go to the Colors box to the Custom tab. If 
the Colors box has been previously closed, follow the steps below to open the Colors box. 

23.	 Select the text that is hard to read 

24.	 Click the font icon drop-down button
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25.	 When the Theme Color dialog box opens, choose the “More Colors” option.

26.	 Be in the Custom tab of the Colors box.
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27.	 Find where it says “Hex” and paste the new hexadecimal number from the Contrast 
Checker. Then press the “Tab” button on the keyboard.

28.	 To the right of the Hex input box there is a box with two colors. The top that says New is 
the color from the contrast checker pasted in, the other is the color that is currently being 
used and is causing the problem for the document.
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29.	 Click on the OK button.

30.	 Now the selected words/sentence with the contrast error has changed color to the one 
from the contrast checker and meets ADA Color Contrast requirements. 

31.	 Now there are no more Hard-to-Read Text Contrast errors. The error has now disappeared 
from the Accessibility Inspection Results.
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